媛代码社区

vue报错:Uncaught TypeError: (0 , vue__WEBPACK_IMPORTED_MODULE_0__.defineComponent) is not a function

技术
cute-Q
· 阅读 173 · 评论 0 · 7 个月前

报错的原因是vue-router的版本和vue版本不兼容的问题,在下载vue路由三方包的时候默认下载的是最新版本,无法与vue2.0兼容,所以需要手动修改三方包的版本,重新安装再运行就解决啦

详细的vue和vue-cli、vue-router、vuex之间适配版本(1条消息) 关于Vue、Vue-router、Vuex、Vue-cli版本_Mangooxx的博客-CSDN博客_vue vuex版本

 

1
帖子评论(0)
发起评论
暂无数据
Loading
推荐帖子
  • 媛代码访谈第 9 期 | 十年开发...
  • 镇魂街简直是太虐啦,眼泪都要哭干了...
  • 大家都是什么时间读书呢?感觉最近读...
  • 如何在公司内部晋升
  • 最近很迷茫,感觉自己什么方面都高不...
社区宗旨
媛代码社区是女性科技从业者的聚集地
我们鼓励:
分享生活经验,日常趣事
晒晒您的作品,讨论讨论技术
也可以吐槽职场,抱怨不公
我们致力于:
让更多的人听到我们的声音
打破社会传统偏见!提升个人能力!
快来加入媛代码大家庭吧!
加入组织
二维码

媛代码社区微信公众号